mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

rssFeeds [Syndicate]


forumforum
 

Old Motifator threads are available in the Archive.

Viewing topic "Problems w/ the New Steinberg USB Driver (2.0.2) On Mac"

     
Posted on: November 27, 2019 @ 01:02 PM
MarkJohnson
Total Posts:  63
Joined  09-03-2013
status: Experienced

I’ve loaded the new Steinberg USB Driver (2.0.2) on my Mac(OSX 10.15.1).

When the new driver is installed:
- The MOXF Editor works
- When in my DAW (Cubase 10.5), only MIDI communicates with the MOXF. No audio or even MIDI to VST instruments works
- One VST (EZDrummer) indicates “Audio engine inactive”
- No audio can be played from any application
- The Cubase>Studio Setup>VST Audio System>Yamaha MOXF6/MOXF8>Control Panel>CoreAudio Device Settings displays Yamaha MOXF6/MOXF8
- There is no longer an icon for the driver at the bottom of the Mac’s System Preferences window

When the new driver is uninstalled:
- The MOXF Editor does not work
- All sound and MIDI work in Cubase
- All audio works across multiple applications
- The Cubase>Studio Setup>VST Audio System>Yamaha MOXF6/MOXF8>Control Panel>CoreAudio Device Settings still displays Yamaha MOXF6/MOXF8
- Still no driver listed at the bottom of the Mac’s System Preferences window

How is it that everything works after the driver is uninstalled?  Is the uninstall function that comes with the driver not actually uninstalling it?If it is actually being uninstalled, what is being used as a functioning driver.  Is there a place I can go to confirm what version of the driver is being used.

Attached is what Cubase reports as the active driver after I’ve uninstalled it.

This has me thoroughly confused.

Image Attachments
Screen Shot 2019-11-27 at 10.28.33 AM.png
  [ Ignore ]  

Posted on: November 27, 2019 @ 03:46 PM
5pinDIN
Avatar
Total Posts:  11152
Joined  09-16-2010
status: Legend

Yamaha claims that the Yamaha Steinberg USB Driver V2.0.2 is compatible with macOS 10.15 (Catalina)…
See https://download.yamaha.com/files/tcm:39-1145524

I’m not a “Mac guy”, so I don’t know how you would verify that the driver is installing properly, and that no earlier version is still on the system.

Hopefully another member will reply. If not, I suggest directly contacting Yamaha support.

  [ Ignore ]  

Posted on: January 12, 2020 @ 08:12 AM
MarkJohnson
Total Posts:  63
Joined  09-03-2013
status: Experienced

SOLVED (finally):  There’s an article on the Yamaha Steinberg site that indicates that there is a system extension that’s blocked on Macs when installing the USB driver.  I don’t remember ever seeing the warning messages that the OS presents during the installation, but even after applying the fix via Preferences>Security & Privacy, it still didn’t take, after which I would just uninstall the driver.  This time, I rebooted my machine *after* making the change and it took.  Who knew?

https://helpcenter.steinberg.de/hc/en-us/articles/115001790330-macOS-Extension-blocked-message-during-hardware-installation

The only issue remaining is that the audio performance of the driver is pretty dicy.  To compensate, I’m having to set and reset the driver’s buffer size between recording and play back. I’m hoping this will be resolved in future releases of the driver, unless anyone is aware of some other configurations I could change to compensate for this behavior.

  [ Ignore ]  


 
     


Previous Topic:

‹‹ MOTIF XF6 and Cubase 7
Next Topic:

    Free notation software from Steinberg ››