mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

newProducts [YOK]

rssFeeds [Syndicate]


forumforum
 

Old Motifator threads are available in the Archive.

Viewing topic "Advanced MIDI question"

     
Posted on: February 10, 2019 @ 03:23 AM
Michiel D
Total Posts:  127
Joined  11-16-2009
status: Pro

Hi there,

I’m using a XS in combination with an ES and 2 sound modules (Nord lead & Korg Arp).
I want to make a setup in which all units work ‘in sync’ and have come up with this configuration:
(Both Motifs in pattern mode, ES syncs on MIDI in (XS clock)…

XS midi OUT to ES midi IN
ES OUT to module 1 (NL)
ES THROUGH to module 2 (KArp)

I want to play module 1 on the ES keyboard (this works fine)
I want to play module 2 on the XS keyboard

All works fine but one problem arises .... when I play module 2 on the XS keyboard the standard piano sound that is on track 3 of the Es also sounds. I want to put this Internal ES sound ‘of’.

So in utility mode of the ES I put te receive channel to ‘off’.
In the XS I put the transmit channel to ‘off’.
But stil the standard piano sound comes along with the sound of module 2, playes on the XS ... ??
The only thing I can come up with is to put the volume of the piano in track 3 (ES) to ‘0’. But I simpele want ‘disconnect’ the MIDI between XS channel 3 and the Internal sound on the ES in track 3 ... must be a way…
Can anyone help me out here? Thanks!!

Kind regards, Michiel

  [ Ignore ]  

Posted on: February 10, 2019 @ 03:35 AM
Michiel D
Total Posts:  127
Joined  11-16-2009
status: Pro

(In both ES and XS pattern mode I put the Internal track ‘off’)

  [ Ignore ]  

Posted on: February 10, 2019 @ 05:15 AM
5pinDIN
Avatar
Total Posts:  10843
Joined  09-16-2010
status: Legend
Michiel D - 10 February 2019 03:23 AM

[...]
So in utility mode of the ES I put te receive channel to ‘off’.

If you’re referring to the Basic Receive Channel, that setting only affects Voice and Performance modes. In Pattern (or Song) mode each Part responds on its assigned receive channel, unaffected by the Utility mode BasicRcvCh setting. See the NOTE at the bottom of page 263 of the ES Owner’s Manual.

 

Michiel D -

In the XS I put the transmit channel to ‘off’.
But stil the standard piano sound comes along with the sound of module 2, playes on the XS ... ??
The only thing I can come up with is to put the volume of the piano in track 3 (ES) to ‘0’. But I simpele want ‘disconnect’ the MIDI between XS channel 3 and the Internal sound on the ES in track 3 ... must be a way…

This might help…
Tracks are MIDI data transmitters.
Parts (not Tracks) are MIDI receivers.

A few details of your setup might provide some insight…
Since Part 3 in the ES is responding to what the XS is sending, I presume that the [3] button is pressed on the XS at the time, and that “module 2” is set to receive on Channel 3. If not, please explain how things are configured.

  [ Ignore ]  

Posted on: February 10, 2019 @ 12:33 PM
Michiel D
Total Posts:  127
Joined  11-16-2009
status: Pro

Thanks for your fast reply, mr 5pinDIN!

Indeed, I selected track 3 in pattern mode on the XS, this triggers the module (set to receive on midi channel 3) but also the Internal sound on track 3 in the ES (while the output switch (INT SW) on track 3 is set to ‘off’.
How to preventie the XS (track 3 in pattern mode played) to trigger the Internal sound assigned to track/part 3 on the ES?
Beslissen putting the volume to ‘0’ ... is there a parameter to be set to ‘off’ of something else ....

I did find another possible solution ... in Mixing mode (on the ES) I press ‘edit’ ... here I can select the ‘recieve channel’ of part 3. When I change this, from ‘3’ to ‘off’ ... the problem seems to be solved ... :  ) Is this the way to go?
Kind regards, Michiel

  [ Ignore ]  

Posted on: February 10, 2019 @ 02:09 PM
5pinDIN
Avatar
Total Posts:  10843
Joined  09-16-2010
status: Legend
Michiel D - 10 February 2019 12:33 PM

Thanks for your fast reply, mr 5pinDIN!

Glad to help.

 

Michiel D -

Indeed, I selected track 3 in pattern mode on the XS, this triggers the module (set to receive on midi channel 3) but also the Internal sound on track 3 in the ES (while the output switch (INT SW) on track 3 is set to ‘off’.

Setting the INT SW “off” prevents the keyboard from triggering the internal tone generator, but external MIDI data can still play it.

 

Michiel D -

How to preventie the XS (track 3 in pattern mode played) to trigger the Internal sound assigned to track/part 3 on the ES?
Beslissen putting the volume to ‘0’ ... is there a parameter to be set to ‘off’ of something else ....

I did find another possible solution ... in Mixing mode (on the ES) I press ‘edit’ ... here I can select the ‘recieve channel’ of part 3. When I change this, from ‘3’ to ‘off’ ... the problem seems to be solved ... :  ) Is this the way to go?
Kind regards, Michiel

Yes - setting the receive channel of the Part to “off” will stop it from responding to external MIDI.

  [ Ignore ]