mySoftware [Updates]

Once you create a user profile on Motifator and update with the appropriate information, the updates shown here will be specific to you.

rssFeeds [Syndicate]


forumforum
 

Old Motifator threads are available in the Archive.

Viewing topic "Making use of USB audio outside of Cubase"

     
Posted on: March 11, 2018 @ 02:15 PM
pblais
Total Posts:  94
Joined  03-05-2015
status: Experienced

Hi,
I’ve been away for a while but hopefully back to MOXF8ing it again.

I have a weird request. I want to stream my MOXF8 but not from the audio lines.  I want to use the USB audio out but can’t seem to get any audio

I have done as suggested in:
http://www.motifator.com/index.php/support/view/moxf6_moxf8_basic_audio_recording

I have installed the latest Yamaha Steinberg USB Driver I think:
https://gyazo.com/e0fa71491d08296d1244eb43a4319ea3

As indicated by my Windows setup:
https://gyazo.com/f2f79e824f9d5f98095a0bb67dab3bab

Which I set to defaut and set to max level as shown:
https://gyazo.com/bf20102a51a3dc6e0358eccd8587c23d

As an experiment, I fired up Audacity. This is what Audacity is reporting for input line device:
https://gyazo.com/14f3dc8ba11e1d9d85e12e43f683621a

With Audacity set to max input level and the MOXF8 DAW LEVEL slider all the way up, there is never any audio coming in to Audacity.
Which would explain why there is nothing coming into Winamp when I try to use it to stream the MOXF8.

I should state here that if I use, let’s say, the headphone output of the MOXF8 as input to Audacity and Winamp, both work good.  The reason I don’t want to use this approach is it is too easy to over drive and over modulate Winamp and everything sounds like you know what.

Also, I have not tried this on a DAW like Cubase.

I am running Windows 64 Pro

Thank you in advance
Pierre

  [ Ignore ]  

Posted on: March 11, 2018 @ 03:31 PM
philwoodmusic
Avatar
Total Posts:  960
Joined  07-01-2013
status: Guru

Please check that you have selected MOXF USB inputs 3 and 4 in Audacity.

Voice audio defaults to 3 and 4, not 1 and 2 as you’d expect.

The MOXF A/D inputs (on the rear) default to 1 and 2.

Your problem is hard to diagnose at this stage, but I can think of a few things that you haven’t mentioned at all.

1 - Recording or Input monitoring. (sometimes called software playthrough)

On any given DAW, if I want to hear the USB audio from a MOXF, I absolutely need to either put the DAW into record, or use input monitoring.  If I do not do either of those, there is absolutely no way I can hear any of the audio being bussed to the DAW.  It hits a dead end.

2 - How are you listening to Audacity?  How is your computer cabled up?

If it is your intention to use the MOXF as the audio interface, then the analog left and right outputs on the MOXF rear are the most sensible way to listen to Audacity.  USB audio on a MOXF is two way. It allows you to bus audio to your DAW to record, but it also allows you to listen back to that audio and anything else in your DAW via the DAW level slider.

The DAW level slider does not control the level of audio going to the DAW, it controls the level of audio coming back from it.

  [ Ignore ]  

Posted on: March 11, 2018 @ 04:54 PM
pblais
Total Posts:  94
Joined  03-05-2015
status: Experienced

Thanks Phil.. My answers, comments and questions beloe

philwoodmusic - 11 March 2018 03:31 PM

Please check that you have selected MOXF USB inputs 3 and 4 in Audacity.

Voice audio defaults to 3 and 4, not 1 and 2 as you’d expect.

The MOXF A/D inputs (on the rear) default to 1 and 2.

I know what you mean.  I have seen the selection options on my other computer using a DAW.  Audacity does not give me the option to select. It just shows me what I showed you in the Audacity screen dump in my last post. That being said, is it possible to go into the menu and swap it from what you just described?

philwoodmusic - 11 March 2018 03:31 PM

2 - How are you listening to Audacity?  How is your computer cabled up?

See the dump below:
I plan to us the headphones output of Audacity to listen and click on button
https://gyazo.com/5af8b1b83a385891bf495cdcf1606031

philwoodmusic - 11 March 2018 03:31 PM

The DAW level slider does not control the level of audio going to the DAW, it controls the level of audio coming back from it.

Thanks, I did not know that.

Thank you again
Pierre

  [ Ignore ]  

Posted on: March 11, 2018 @ 10:41 PM
philwoodmusic
Avatar
Total Posts:  960
Joined  07-01-2013
status: Guru

hmm.

Can you tell me what other options you have on all of those drop down menus, if any?

or screen cap them.

It may also be that Audacity only supports the first two channels of any audio interface..

I expect the I/O to be basic, somehow.

  [ Ignore ]  

Posted on: March 12, 2018 @ 08:53 AM
pblais
Total Posts:  94
Joined  03-05-2015
status: Experienced
philwoodmusic - 11 March 2018 10:41 PM

hmm.

Can you tell me what other options you have on all of those drop down menus, if any?

or screen cap them.

It may also be that Audacity only supports the first two channels of any audio interface..

I expect the I/O to be basic, somehow.

Thanks again Phil..

Unfortunately, there is no pull down further than what you see in that last screen cap I showed for Audacity.  Initially there was a pull down to decide what I wanted for input and output devices.  I selected the MOXF for input and Headphones for output. (by the way the MOXF was an output option too)

Thanks again
Pierre

  [ Ignore ]  

Posted on: March 12, 2018 @ 01:25 PM
philwoodmusic
Avatar
Total Posts:  960
Joined  07-01-2013
status: Guru

The two main things that I believe you need to look into are:

1 - If the MOXF is being used as your audio interface (that’s what it looks like), try listening through the headphones socket on your MOXF with the DAW level slider up, or better still connect the MOXF’s left and right analog outputs to some kind of amplification.

Remember that your MOXF becomes your sound card in this situation.

2 - Since it is likely that Audacity will only see USB audio 1 and 2 from your MOXF or any other interface, you need to look into changing the routing for Voice Audio from 3 and 4 to 1 and 2 on your MOXF.  That’s in the USB I/O page in utility.

Where it says 3/4, change it to 1/2

You may also have to put your MOXF into 1StereoRecord rather than 2StereoRecord.

Image Attachments
Fig2.png
  [ Ignore ]  

Posted on: March 12, 2018 @ 09:38 PM
pblais
Total Posts:  94
Joined  03-05-2015
status: Experienced
philwoodmusic - 12 March 2018 01:25 PM

You may also have to put your MOXF into 1StereoRecord rather than 2StereoRecord.

That did it… Works great now
Thanks Phil… One last question.  Is there any to control the output level going out the USB port?

Thank you again
Pierre

  [ Ignore ]  

Posted on: March 12, 2018 @ 11:51 PM
philwoodmusic
Avatar
Total Posts:  960
Joined  07-01-2013
status: Guru

Glad that worked.

You can’t control the overall level of the USB audio with a main level fader because it’s a digital output and just a bunch of code being sent.  You’ll notice that the main volume slider doesn’t affect it at all and rightly so.

What you CAN do, is edit the levels of individual voices, parts or songs at their source.

For example, edit the level of a VOICE so you’re happy with it and store it to a USER VOICE location, OR adjust levels on the graphical faders in the MIXING for a song you might have in SONG MODE

  [ Ignore ]